View unanswered posts | View active topics It is currently Mon Dec 10, 2018 8:09 pm



Reply to topic  [ 40 posts ]  Go to page 1, 2, 3, 4  Next
 Mintbox Mini 2 Pro: Problems after fresh install 
Author Message

Joined: Tue Jul 17, 2018 1:41 pm
Posts: 2
Post Mintbox Mini 2 Pro: Problems after fresh install
TL;DR:
Are there any BIOS- or Grub-Settings Linux Mint needs to work (particularly shutdown) correctly?


The whole story:
As a long-term XFCE-user I ditched the delivered install in favor of the XFCE-Edition of Linux Mint (of course without doing a backup before ;) )
After a series of problems, now it's running quite fine beside of at least two problems:

1. When I shutdown the box and start it again after only some minutes, everything is fine.
But after powering it on after a few hours, the box hangs.
The displays shows nothing, all Lights are green, NumLock is on, nothing happens.
Today I left it in this state and after a while some messages showed up, pls see the attachment for it.
The only remedy is to long press the power button. All light go off and afterwards it's starting fine.

2. After either suspending or shutting down, in both cases the power button went orange, LED1 and LED2 stayed on and green.
Is this the expected behavior?
Especially in contrast to all lights going off when pressing the power button for a longer time?


Before installing, the BIOS was set to defaults. The only changes I made were setting "OS Selection" to "Linux" and enabling "Wake On Lan" in "Chipset -> South Cluster Configuration -> Misc. Config."
I installed from the image downloaded from the Linux Mint site and applied all updates.


I supposed (better: hoped ;) ), that there could be any BIOS-Settings or kernel parameters to solve these problems.


Thanks in advance,
Christian


Attachments:
IMG_20180721_125841.jpg
IMG_20180721_125841.jpg [ 1.88 MiB | Viewed 1201 times ]
Sat Jul 21, 2018 2:58 pm
Profile
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 194
Post Re: Mintbox Mini 2 Pro: Problems after fresh install
Which Kernel you're operating system is working on?
Also, what is the BIOS version?

I'd recommend to update both of them:

BIOS update - http://fit-pc.com/wiki/index.php/Fitlet2:_BIOS_Update
Kernel update - Through the Linux mint updating service.
Could also be done through the shell if you're comfortable with it.


Tue Jul 24, 2018 12:39 pm
Profile

Joined: Tue Jul 17, 2018 1:41 pm
Posts: 2
Post Re: Mintbox Mini 2 Pro: Problems after fresh install
tamir wrote:
I'd recommend to update both of them:
As stated, of course i did apply all updates. At the time of writing my first posting, it was:
Code:
uname -r
4.15.0-24-generic
Today I checked again for updates, now it's:
Code:
4.15.0-29-generic
Of course, without knowing by now, if this changes anything (which, honestly, i do not expect :| )

BIOS was delivered with the latest version:
Code:
# dmidecode 3.1
...
BIOS Information
        Vendor: American Megatrends Inc.
        Version: FLT2.MBM2.0.40.01.00
        Release Date: 07/05/2018
...



Any other other suggestions?


Tue Jul 24, 2018 4:18 pm
Profile
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 194
Post Re: Mintbox Mini 2 Pro: Problems after fresh install
Thank you for the information

We are not aware of such issue or special configuration to be done at BIOS level to address such behavior.
I'd suggest to try and install the recent mint 19 TARA:
https://linuxmint.com/download.php
It is known to run good and stable.

The LED behavior you're describing is normal, when the power button LED is lit in orange, the others are in green.
We formed a manual to control these:
http://fit-pc.com/wiki/index.php/FAQ:fi ... nt_LEDs.3F

If there are still settings change at the BIOS level, I'd suggest to have them restored to defaults prior to the re-installation, to confirm stable behavior.


Wed Aug 01, 2018 2:11 pm
Profile

Joined: Mon Aug 06, 2018 3:29 am
Posts: 6
Post Re: Mintbox Mini 2 Pro: Problems after fresh install
Hello there,

I bought recently MBM2 Pro and i would like to say that i have the same problems also, with the only difference that i use linux mint cinnamon and not xfce. I even created a thread in the linux mint forum https://forums.linuxmint.com/viewtopic. ... 6&t=274942

Any help to solve this problem will be appreciated.


Mon Aug 06, 2018 3:40 am
Profile

Joined: Tue Jul 24, 2018 8:37 am
Posts: 9
Post Re: Mintbox Mini 2 Pro: Problems after fresh install
well, I have installed Debian 9 on my Fitlet2, without any problems.
apart from the boot-order, I did not change anything in the BIOS.


Mon Aug 06, 2018 9:32 am
Profile

Joined: Mon Aug 06, 2018 3:29 am
Posts: 6
Post Re: Mintbox Mini 2 Pro: Problems after fresh install
fred44nl wrote:
well, I have installed Debian 9 on my Fitlet2, without any problems.
apart from the boot-order, I did not change anything in the BIOS.

That's very nice, your system and machine is working perfectly. :)

Unfortunately this is not the case for me and the person who created this thread, there is a serious problem that needs a solution. And to install a different linux distro to my mintbox it's not a solution, just saying.


Mon Aug 06, 2018 11:50 am
Profile
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 194
Post Re: Mintbox Mini 2 Pro: Problems after fresh install
SoulRescuer wrote:
Hello there,

I bought recently MBM2 Pro and i would like to say that i have the same problems also, with the only difference that i use linux mint cinnamon and not xfce. I even created a thread in the linux mint forum https://forums.linuxmint.com/viewtopic. ... 6&t=274942

Any help to solve this problem will be appreciated.


Please make sure the your MBM2 has the latest BIOS update:
http://fit-pc.com/wiki/index.php/Fitlet2:_BIOS_Update

And install the most latest distribution of mint, currently mint 19 TARA:
https://www.linuxmint.com/release.php?id=32

Also updating Kernel is advised, last time I checked it was 4.15.0-29.
Can be conveniently achieved from the GUI update manager.


Thu Aug 09, 2018 1:55 pm
Profile

Joined: Mon Aug 06, 2018 3:29 am
Posts: 6
Post Re: Mintbox Mini 2 Pro: Problems after fresh install
tamir wrote:
Please make sure the your MBM2 has the latest BIOS update:
http://fit-pc.com/wiki/index.php/Fitlet2:_BIOS_Update

I have the latest BIOS update! More specifically i have FLT2.NBR.0.40.01.00 Unbranded version, with the default BIOS settings.

I even sent you email to ask if you can upload the latest BIOS version but Linux Mint branded. You replied that there will be a release of a new linux mint branded version in the fitlet2 bios file page by the end of Aug. 18. I'm waiting for that too.

tamir wrote:
And install the most latest distribution of mint, currently mint 19 TARA:
https://www.linuxmint.com/release.php?id=32

Also updating Kernel is advised, last time I checked it was 4.15.0-29.
Can be conveniently achieved from the GUI update manager.

Right now i am running LM 19 Tara with Cinnamon (installed in UEFI mode) and my kernel is 4.15.0-30-generic.

Is there any other suggestion? Anything we can do? We still have this problem and it's a serious one.


Tue Aug 14, 2018 2:32 pm
Profile
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 194
Post Re: Mintbox Mini 2 Pro: Problems after fresh install
SoulRescuer wrote:
tamir wrote:
Please make sure the your MBM2 has the latest BIOS update:
http://fit-pc.com/wiki/index.php/Fitlet2:_BIOS_Update

I have the latest BIOS update! More specifically i have FLT2.NBR.0.40.01.00 Unbranded version, with the default BIOS settings.

I even sent you email to ask if you can upload the latest BIOS version but Linux Mint branded. You replied that there will be a release of a new linux mint branded version in the fitlet2 bios file page by the end of Aug. 18. I'm waiting for that too.

tamir wrote:
And install the most latest distribution of mint, currently mint 19 TARA:
https://www.linuxmint.com/release.php?id=32

Also updating Kernel is advised, last time I checked it was 4.15.0-29.
Can be conveniently achieved from the GUI update manager.

Right now i am running LM 19 Tara with Cinnamon (installed in UEFI mode) and my kernel is 4.15.0-30-generic.

Is there any other suggestion? Anything we can do? We still have this problem and it's a serious one.


I will escalate this issue to our R&D and return to as soon as possible.


Wed Aug 15, 2018 10:48 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 40 posts ]  Go to page 1, 2, 3, 4  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.