View unanswered posts | View active topics It is currently Mon Jul 23, 2018 7:17 am



Reply to topic  [ 3 posts ] 
 Automatic power up on USB with Logitech camera 
Author Message

Joined: Thu May 07, 2009 2:32 pm
Posts: 32
Post Automatic power up on USB with Logitech camera
I have come across a very strange problem. When I have
a Logitech camera plugged into the either of the rear USB 2.0
ports, the machine powers up about 3 seconds after being shut down
(shutdown via software). If I move the camera to any of the front USB 2.0
ports, the machine shuts down and stays off.

I have two IPCs and have tested both with two different Logitech cameras.
Also, when I have keyboard/mouse plugged into the same rear ports,
the machine stays off.

I should mention that I run Linux Mint 17.3 on both machine (have also tried Fedora23 and Mint 17.2). The typical command given is "shutdown -h now" or by the "Shutdown" menu option. The shutdown works fine with Windows 10.

Is there some sort of "power up on USB" in the BIOS that fires because of some
left over static in the camera?

Jens


Wed Jan 06, 2016 5:41 pm
Profile
Post Re: Automatic power up on USB with Logitech camera
It may have some connection to USB power functionality on Intense PC:
http://fit-pc.com/wiki/index.php/FAQ:Intense_PC#USB_ports_power_behavior

Intense PC USB port power behavior:
1. FACE Module ports – USB power always on (S0, S3, S4, S5).
2. Motherboard back panel ports – USB power on in S0, S3 but off in S4, S5.

S0 – active
S3 – sleep
S4 – hibernate
S5 – shutdown

And of course may be relevant to OS/SW settings and 3rd party camera used.


Thu Jan 07, 2016 11:48 am

Joined: Thu May 07, 2009 2:32 pm
Posts: 32
Post Re: Automatic power up on USB with Logitech camera
Solution found:

It seems to be related to the power saving features for USB in Linux.
What lead me to the solution was that I got a lot of messages like
usb 3-1.6: reset high-speed USB device number 4 using ehci-pci
in the log (which was slowing down the backgammon game gnubg!!!).

I changed a line in /etc/default/grub to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"
and ran sudo grub-update.

Upon reboot the messages above were gone and now the machine powers off as it should.


Wed Jan 13, 2016 3:27 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.