View unanswered posts | View active topics It is currently Sat Jan 25, 2020 11:06 am

Reply to topic  [ 4 posts ] 
 Intense PC 2 won't switch on 
Author Message

Joined: Fri Jul 04, 2014 2:41 pm
Posts: 1
Post Intense PC 2 won't switch on
Hi all,

I just got my Intense PC 2 Barebone. I installed 16 GB of DDR3 RAM, installed my SSD hard drive, connected power and tried to switch it on, but it simply doesn't.

The I/O button is glowing red when the power is connected and nothing else is happening. Tried clicking the on button many times, tried removing hard drive, tried removing RAM. Always it's the same behaviour - red I/O button, IPC2 logo not glowing.

Any help?



Fri Jul 04, 2014 2:48 pm
Post Re: Intense PC 2 won't switch on
It must use DDR3L memories (1.35V), and of course non-ECC.

Wed Jul 09, 2014 11:33 am

Joined: Thu Mar 05, 2015 1:02 am
Posts: 2
Post Re: Intense PC 2 won't switch on
My IPC2 i7 SSD won't turn on, once I connect the power cord the green light turns on and then red again and this keeps going on. Please let me know what is the problem. I bought the IPC 2 that comes with everything installed (RAM and SSD and OS). I bought two of them - one works just fine, the other one doesn't even turn on.



Thu Mar 05, 2015 1:22 am
Post Re: Intense PC 2 won't switch on
Have you tried to switch the storage/memory from the "working" unit into the "non-working". What are your observations?
If the above won't change a thing, it is DOA, then follow an RMA for it:

Wed Mar 11, 2015 12:22 pm
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.