View unanswered posts | View active topics It is currently Wed Jul 17, 2019 11:09 pm



Reply to topic  [ 12 posts ]  Go to page 1, 2  Next
 IPC2 serial ports... 
Author Message

Joined: Thu Jul 07, 2016 4:52 pm
Posts: 5
Post IPC2 serial ports...
Hello,

I have an IPC2, i7-4600U @ 2.10 GHz (Haswell)
The serial ports incoming data is VERY slow. Transmit is fine.
The data is going out com 2 and should be coming in com 1 without delay.
It takes seconds for the data to appear on com 1.

These setup works fine on other computers.
All drivers appear to be up to date and nothing in the serial port configuration is different than any other computer we use.

Any ideas? I am really at a loss as to the issue.

Regards,

Mark


Thu Jul 07, 2016 5:00 pm
Profile
Post Re: IPC2 serial ports...
Please check all your HW on both ends.
Please try to use other equipment, try different serial port.


Mon Jul 11, 2016 11:54 am

Joined: Thu Jul 07, 2016 4:52 pm
Posts: 5
Post Re: IPC2 serial ports...
Hi,

Thanks for the response. I performed many test before I posted the message. In the end I had to use a second computer to run one program.

The issue is easy to reproduce. On the IPC2, connect one serial port to another. Start two copies of HyperTerminal, one for each port.
Type 12345 in one window and see how long it takes for the text to appear in the other window. Should be instantaneous. It takes several seconds.

Using the same cable from another computer serial port to IPC2, no problem. Only when IPC2 port to port is there a problem.

Regards,

Mark


Mon Jul 11, 2016 12:39 pm
Profile

Joined: Thu Jul 07, 2016 4:52 pm
Posts: 5
Post Re: IPC2 serial ports...
Hello,

This issue is not resolved. I did more testing.

1) I used a cable I have used for many years to communicate with a device.
2) I tried Com 1 and Com 3, using the FitPC micro USB to 9 pin cable, connected to my cable, no joy. Communications will not work.
3) Take the cable end plugged into the FitPC micro cable, plug it into a USB to serial convertor, communications works, no problem.

So, either the serial ports are the issue or the cable from FitPC is the issue and I am unsure which one.

I would "assume" the FitPC cable exposes the pins to appear as a standard serial port.

Settings are 19200, 8-N-1, no handshaking.
The driver data for Com 1,3 indicate all is OK
Using Windows 7 64 bit.

Ideas?

Mark


Sat Jul 23, 2016 3:56 pm
Profile
Post Re: IPC2 serial ports...
Compulab cable is mini serial to DB9. If you had a successful operation when the cable plugged into USB to serial converter, then the cable is totally fine.
Please refer to the following FAQ:
http://fit-pc.com/wiki/index.php/FAQ:IPC2#IPC2_serial_ports

Probably some interop exist between the device you're trying to establish comms. Please try other serial device.


Mon Jul 25, 2016 6:55 am

Joined: Thu Jul 07, 2016 4:52 pm
Posts: 5
Post Re: IPC2 serial ports...
Hello,

>then the cable is totally fine.

OK, then it is the hardware port or driver.

>Please try other serial device.

Please reread my earlier post. You can test the failure by using two com ports on the IPC connected together.

> Please try other serial device.

I did that is why I posted that this issue continues.

I am only using TX/RX/GND. It should work with all ports.

Mark


Mon Jul 25, 2016 1:14 pm
Profile

Joined: Tue Apr 14, 2015 8:59 am
Posts: 4
Post Re: IPC2 serial ports...
Hi
I am having troubles also with the serial ports on IPC2. I am on ubuntu 14.04 and need to make at least 2 serial ports works.

So far, it seems the trouble come from IRQ misconfiguration. I am however unable to find a solution.
Do you have found a way to have the ports working ?
Currently we are falling back to use USB-to-Serial ports.

By the way, what are the correct IRQ for the ports ?
In the BIOS, I can read :
UART1 : nothing in the BIOS
UART2 : 2f8 IRQ3
UART3 : 3e8 IRQ4

But in Ubuntu, the detection seems to fail :
UART1 : ttyS0 3f8 IRQ4 <- Port don't works, very long delays
UART2 : ttyS1 2f8 IRQ3 <- This one works good
UART3 : ttyS2 3e8 IRQ0 <- This one 'works' but not on fast baudrates (115200) (IRQ0 means polling in fact and we have overruns)

I have tried to change the IRQ with the 'setserial' command but no luck (it changes it but don't work better).


Mon Jan 23, 2017 9:13 pm
Profile

Joined: Thu Jul 07, 2016 4:52 pm
Posts: 5
Post Re: IPC2 serial ports...
rrossi wrote:
Hi
...it seems the trouble come from IRQ misconfiguration.


The problem for me was the assigned com number (COM1, COM2, etc.) was not correct for the hardware configuration (I/O range, IRQ).

So, I renamed the ports to COM14, COM15 and COM16 (could have been any value except 1-3) and then renamed the ports to the correct COM1-3.

I can only guess the issue was because the OS was installed on the MSATA from a cloned drive and then the drivers updated for the FitPC.

I suspect it was the cloning that caused the issue.

The problem appears to be fixed but I have not really tested it. The one port started working after the changed and I moved on. I just need the one port and the other port was UBS-serial for VM.


Mon Jan 23, 2017 9:24 pm
Profile

Joined: Tue Apr 14, 2015 8:59 am
Posts: 4
Post Re: IPC2 serial ports...
After further tests, I have discovered that changing the "UEFI boot" parameter in the BIOS modifies the way Serial ports are detected. After changing it, I had to reinstall Ubuntu however.

I managed to have serial ports 2 and 3 working by enabling both "UEFI boot" and "Legacy boot" parameters in the BIOS and installing ubuntu in uefi.
Then, I had to install setserial program and force the setting of port3 to have IRQ11.

I however wasn't able to have port 1 working. Maybe disabling "Legacy boot" can help ?

@Mark : Maybe your workaround is consistent with my tests, as setting a different name can change the default IRQ setting the OS applies.


Tue Jan 24, 2017 4:07 pm
Profile
Post Re: IPC2 serial ports...
Which of the serial ports shown in this FAQ you cannot operate?
http://fit-pc.com/wiki/index.php/FAQ:IPC2#IPC2_serial_ports

Embedded Controller serial port is a "black box" to us and operate ad-hoc. Not all devices supported on it.


Wed Feb 08, 2017 2:46 pm
Display posts from previous:  Sort by  
Reply to topic   [ 12 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.