View unanswered posts | View active topics It is currently Mon Dec 09, 2019 3:03 am



Reply to topic  [ 10 posts ] 
 USB ports not functioning 
Author Message

Joined: Sat Nov 03, 2018 4:28 pm
Posts: 4
Post USB ports not functioning
Hi. I have the MBM2 Pro

The rear (standard) USB ports are working fine. The front (USB-3) ports function intermittently sometimes and sometimes not at all. I've tested multiple inputs (mouse, keyboard, USB stick, HDD, etc) all with similar behaviour. Yesterday I was able to get the ports to exhibit a successful connect and multiple failures and logged it:

dmesg output:

Code:
[    0.000000] ACPI: SSDT 0x0000000079E6EEA0 001084 (v02 INTEL  UsbCTabl 00000003 BRXT 0100000D)
[    0.189208] ACPI: bus type USB registered
[    0.189208] usbcore: registered new interface driver usbfs
[    0.189208] usbcore: registered new interface driver hub
[    0.189208] usbcore: registered new device driver usb
[    1.977892] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.977966] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    1.977996] uhci_hcd: USB Universal Host Controller Interface driver
[    1.978416] xhci_hcd 0000:00:15.0: new USB bus registered, assigned bus number 1
[    1.979788] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.979791] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.979794] usb usb1: Product: xHCI Host Controller
[    1.979797] usb usb1: Manufacturer: Linux 4.15.0-38-generic xhci-hcd
[    1.979800] usb usb1: SerialNumber: 0000:00:15.0
[    1.980256] hub 1-0:1.0: USB hub found
[    1.981812] xhci_hcd 0000:00:15.0: new USB bus registered, assigned bus number 2
[    1.981820] xhci_hcd 0000:00:15.0: Host supports USB 3.0  SuperSpeed
[    1.981892] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003
[    1.981896] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.981898] usb usb2: Product: xHCI Host Controller
[    1.981901] usb usb2: Manufacturer: Linux 4.15.0-38-generic xhci-hcd
[    1.981904] usb usb2: SerialNumber: 0000:00:15.0
[    1.982382] hub 2-0:1.0: USB hub found
[    2.332093] usb 1-3: new low-speed USB device number 2 using xhci_hcd
[    2.499623] usb 1-3: New USB device found, idVendor=24f0, idProduct=0137
[    2.499625] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    2.499627] usb 1-3: Product: Das Keyboard Model S
[    2.499629] usb 1-3: Manufacturer: Metadot - Das Keyboard
[    2.648089] usb 1-4: new high-speed USB device number 3 using xhci_hcd
[    2.796156] usb 1-4: New USB device found, idVendor=0409, idProduct=005a
[    2.796160] usb 1-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.796596] hub 1-4:1.0: USB hub found
[    2.924126] usb 1-8: new full-speed USB device number 4 using xhci_hcd
[    3.077387] usb 1-8: New USB device found, idVendor=8087, idProduct=0a2b
[    3.077391] usb 1-8: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    3.106865] usbcore: registered new interface driver usbhid
[    3.106867] usbhid: USB HID core driver
[    3.109763] input: Metadot - Das Keyboard Das Keyboard Model S as /devices/pci0000:00/0000:00:15.0/usb1/1-3/1-3:1.0/0003:24F0:0137.0001/input/input1
[    3.156203] usb 1-4.1: new full-speed USB device number 5 using xhci_hcd
[    3.168604] hid-generic 0003:24F0:0137.0001: input,hidraw0: USB HID v1.10 Keyboard [Metadot - Das Keyboard Das Keyboard Model S] on usb-0000:00:15.0-3/input0
[    3.168823] input: Metadot - Das Keyboard Das Keyboard Model S as /devices/pci0000:00/0000:00:15.0/usb1/1-3/1-3:1.1/0003:24F0:0137.0002/input/input2
[    3.228860] hid-generic 0003:24F0:0137.0002: input,hidraw1: USB HID v1.10 Device [Metadot - Das Keyboard Das Keyboard Model S] on usb-0000:00:15.0-3/input1
[    3.259348] usb 1-4.1: New USB device found, idVendor=046d, idProduct=c526
[    3.259352] usb 1-4.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.259354] usb 1-4.1: Product: USB Receiver
[    3.259356] usb 1-4.1: Manufacturer: Logitech
[    3.262483] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:15.0/usb1/1-4/1-4.1/1-4.1:1.0/0003:046D:C526.0003/input/input3
[    3.262932] hid-generic 0003:046D:C526.0003: input,hidraw2: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:15.0-4.1/input0
[    3.264750] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:15.0/usb1/1-4/1-4.1/1-4.1:1.1/0003:046D:C526.0004/input/input4
[    3.324841] hid-generic 0003:046D:C526.0004: input,hiddev0,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:15.0-4.1/input1
[    6.094330] usbcore: registered new interface driver btusb
[10304.462370] usb 1-6: new high-speed USB device number 6 using xhci_hcd
[10304.616007] usb 1-6: New USB device found, idVendor=13fe, idProduct=3623
[10304.616012] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[10304.616014] usb 1-6: Product: STORE N GO
[10304.616016] usb 1-6: Manufacturer: Verbatim
[10304.616018] usb 1-6: SerialNumber: 079B0209F010F7C1
[10304.656314] usb-storage 1-6:1.0: USB Mass Storage device detected
[10304.662320] scsi host1: usb-storage 1-6:1.0
[10304.663064] usbcore: registered new interface driver usb-storage
[10304.668630] usbcore: registered new interface driver uas
[10369.494392] usb usb1-port6: disabled by hub (EMI?), re-enabling...
[10369.494410] usb 1-6: USB disconnect, device number 6
[10370.591471] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10371.491310] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10371.491421] usb usb1-port6: attempt power cycle
[10372.707387] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10373.607264] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10373.607391] usb usb1-port6: unable to enumerate USB device
[10425.121046] usb 1-6: new high-speed USB device number 11 using xhci_hcd
[10425.274946] usb 1-6: New USB device found, idVendor=13fe, idProduct=3623
[10425.274955] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[10425.274961] usb 1-6: Product: STORE N GO
[10425.274966] usb 1-6: Manufacturer: Verbatim
[10425.274971] usb 1-6: SerialNumber: 079B0209F010F7C1
[10425.276150] usb-storage 1-6:1.0: USB Mass Storage device detected
[10425.276586] scsi host1: usb-storage 1-6:1.0
[10426.457081] usb 1-6: reset high-speed USB device number 11 using xhci_hcd
[10427.201049] usb 1-6: reset high-speed USB device number 11 using xhci_hcd
[10427.497024] usb 1-6: reset high-speed USB device number 11 using xhci_hcd
[10427.789099] usb 1-6: reset high-speed USB device number 11 using xhci_hcd
[10428.089039] usb 1-6: reset high-speed USB device number 11 using xhci_hcd
[10428.261634] usb usb1-port6: disabled by hub (EMI?), re-enabling...
[10428.261651] usb 1-6: USB disconnect, device number 11
[10429.480737] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10430.380732] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10430.380830] usb usb1-port6: attempt power cycle
[10431.596803] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10432.496570] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10432.496697] usb usb1-port6: unable to enumerate USB device
[10448.608026] usb 1-6: new high-speed USB device number 16 using xhci_hcd
[10448.765611] usb 1-6: New USB device found, idVendor=13fe, idProduct=3623
[10448.765620] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[10448.765625] usb 1-6: Product: STORE N GO
[10448.765630] usb 1-6: Manufacturer: Verbatim
[10448.765635] usb 1-6: SerialNumber: 079B0209F010F7C1
[10448.767860] usb-storage 1-6:1.0: USB Mass Storage device detected
[10448.768626] scsi host1: usb-storage 1-6:1.0
[10449.804760] usb usb1-port6: disabled by hub (EMI?), re-enabling...
[10449.804785] usb 1-6: USB disconnect, device number 16
[10450.107885] usb 1-6: new high-speed USB device number 17 using xhci_hcd
[10450.265788] usb 1-6: New USB device found, idVendor=13fe, idProduct=3623
[10450.265797] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[10450.265803] usb 1-6: Product: STORE N GO
[10450.265808] usb 1-6: Manufacturer: Verbatim
[10450.265812] usb 1-6: SerialNumber: 079B0209F010F7C1
[10450.267852] usb-storage 1-6:1.0: USB Mass Storage device detected
[10450.268569] scsi host1: usb-storage 1-6:1.0
[10451.428012] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10451.724162] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10451.983922] usb 1-6: device descriptor read/64, error -71
[10452.219813] usb 1-6: device descriptor read/64, error -71
[10452.455742] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10452.748253] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10453.039908] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10453.340032] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10453.632181] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10453.924065] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10454.220126] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10454.515921] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10454.812097] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10455.091930] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10455.384103] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10455.675898] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10455.967904] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10456.267784] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10456.564107] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10456.844064] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10457.135996] usb 1-6: reset high-speed USB device number 17 using xhci_hcd
[10457.285285] usb 1-6: device firmware changed
[10457.285482] usb 1-6: USB disconnect, device number 17
[10457.467467] usb 1-6: new high-speed USB device number 18 using xhci_hcd
[10463.595429] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10464.495378] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10464.495520] usb usb1-port6: attempt power cycle
[10465.711223] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10466.611414] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10466.611548] usb usb1-port6: unable to enumerate USB device
[10473.050970] usb 1-6: new high-speed USB device number 22 using xhci_hcd
[10473.205161] usb 1-6: New USB device found, idVendor=13fe, idProduct=3623
[10473.205170] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[10473.205176] usb 1-6: Product: STORE N GO
[10473.205181] usb 1-6: Manufacturer: Verbatim
[10473.205185] usb 1-6: SerialNumber: 079B0209F010F7C1
[10473.206150] usb-storage 1-6:1.0: USB Mass Storage device detected
[10473.206949] scsi host1: usb-storage 1-6:1.0
[10474.233893] usb usb1-port6: disabled by hub (EMI?), re-enabling...
[10474.233912] usb 1-6: USB disconnect, device number 22
[10475.406909] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10476.306888] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10476.307006] usb usb1-port6: attempt power cycle
[10477.522838] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10478.422806] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10478.422925] usb usb1-port6: unable to enumerate USB device
[10484.890468] usb 1-6: new high-speed USB device number 27 using xhci_hcd
[10485.048215] usb 1-6: New USB device found, idVendor=13fe, idProduct=3623
[10485.048224] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[10485.048230] usb 1-6: Product: STORE N GO
[10485.048235] usb 1-6: Manufacturer: Verbatim
[10485.048240] usb 1-6: SerialNumber: 079B0209F010F7C1
[10485.050163] usb-storage 1-6:1.0: USB Mass Storage device detected
[10485.051764] scsi host1: usb-storage 1-6:1.0
[10486.112612] usb usb1-port6: disabled by hub (EMI?), re-enabling...
[10486.112630] usb 1-6: USB disconnect, device number 27
[10487.302398] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10488.202369] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10488.202487] usb usb1-port6: attempt power cycle
[10489.418321] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10492.798172] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10493.698130] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10493.698259] usb usb1-port6: attempt power cycle
[10494.914007] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10495.814040] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10495.814168] usb usb1-port6: unable to enumerate USB device
[10502.305752] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10503.205730] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10503.205858] usb usb1-port6: attempt power cycle
[10504.421517] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10505.321657] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[10505.321769] usb usb1-port6: unable to enumerate USB device
[10591.745884] usb 1-6: new high-speed USB device number 40 using xhci_hcd
[10591.903475] usb 1-6: New USB device found, idVendor=13fe, idProduct=3623
[10591.903482] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[10591.903485] usb 1-6: Product: STORE N GO
[10591.903487] usb 1-6: Manufacturer: Verbatim
[10591.903488] usb 1-6: SerialNumber: 079B0209F010F7C1
[10591.904472] usb-storage 1-6:1.0: USB Mass Storage device detected
[10591.906426] scsi host1: usb-storage 1-6:1.0
[10593.629951] usb 1-6: reset high-speed USB device number 40 using xhci_hcd
[10593.945921] usb 1-6: reset high-speed USB device number 40 using xhci_hcd


I'm noticing that it may be related to unit temperature but it's not definite. So far though it seems I'm able to get the intermittent functionality when the unit is above ~55C. Anything below ~55C and the ports do not function at all.

Thanks


Sat Nov 03, 2018 4:38 pm
Profile
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 384
Post Re: USB ports not functioning
In order to eliminate HW issue, please try to troubleshoot through a LiveUSB Linux mint.
Please follow the below guide to prepare the bootable device, and try to check the USB ports under LiveUSB environment:
http://fit-pc.com/wiki/index.php/Intel: ... ux_Mint_19

55 Celsius is normal temperature.


Sun Nov 04, 2018 7:50 am
Profile

Joined: Sat Nov 03, 2018 4:28 pm
Posts: 4
Post Re: USB ports not functioning
Thanks Tamir. I booted the unit with Ubuntu 12.04 LTS on a USB. I had to use the back USB ports. The BIOS will not boot from the front ports. After booting, I tried a few USB sticks in the front ports. No success. dmesg from Ubuntu below:

Code:
[    0.000000] ACPI: SSDT 0x0000000079EA8EA0 001084 (v02 INTEL  UsbCTabl 00000003 BRXT 0100000D)
[    0.176080] ACPI: bus type USB registered
[    0.176106] usbcore: registered new interface driver usbfs
[    0.176123] usbcore: registered new interface driver hub
[    0.176146] usbcore: registered new device driver usb
[   14.319650] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[   14.319696] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[   14.319729] uhci_hcd: USB Universal Host Controller Interface driver
[   14.320151] xhci_hcd 0000:00:15.0: new USB bus registered, assigned bus number 1
[   14.321543] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[   14.321547] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[   14.321550] usb usb1: Product: xHCI Host Controller
[   14.321552] usb usb1: Manufacturer: Linux 4.15.0-29-generic xhci-hcd
[   14.321555] usb usb1: SerialNumber: 0000:00:15.0
[   14.321902] hub 1-0:1.0: USB hub found
[   14.323484] xhci_hcd 0000:00:15.0: new USB bus registered, assigned bus number 2
[   14.323562] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003
[   14.323565] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[   14.323567] usb usb2: Product: xHCI Host Controller
[   14.323570] usb usb2: Manufacturer: Linux 4.15.0-29-generic xhci-hcd
[   14.323572] usb usb2: SerialNumber: 0000:00:15.0
[   14.323883] hub 2-0:1.0: USB hub found
[   14.387402] acpi USBC000:00: hash matches
[   14.664134] usb 1-3: new high-speed USB device number 2 using xhci_hcd
[   14.813537] usb 1-3: New USB device found, idVendor=1609, idProduct=3a04
[   14.813541] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   14.813543] usb 1-3: Product: USB Disk
[   14.813545] usb 1-3: Manufacturer: Flash
[   14.813547] usb 1-3: SerialNumber: 3727063909EE839929968
[   14.940209] usb 1-4: new low-speed USB device number 3 using xhci_hcd
[   15.095714] usb 1-4: New USB device found, idVendor=24f0, idProduct=0137
[   15.095718] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   15.095720] usb 1-4: Product: Das Keyboard Model S
[   15.095722] usb 1-4: Manufacturer: Metadot - Das Keyboard
[   15.236251] usb 1-6: new full-speed USB device number 4 using xhci_hcd
[   15.388061] usb 1-6: New USB device found, idVendor=046d, idProduct=c526
[   15.388064] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   15.388066] usb 1-6: Product: USB Receiver
[   15.388068] usb 1-6: Manufacturer: Logitech
[   15.516050] usb 1-8: new full-speed USB device number 5 using xhci_hcd
[   15.664962] usb 1-8: New USB device found, idVendor=8087, idProduct=0a2b
[   15.664964] usb 1-8: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[   15.677663] usb-storage 1-3:1.0: USB Mass Storage device detected
[   15.677839] scsi host1: usb-storage 1-3:1.0
[   15.677977] usbcore: registered new interface driver usb-storage
[   15.679874] usbcore: registered new interface driver uas
[   15.694466] usbcore: registered new interface driver usbhid
[   15.694469] usbhid: USB HID core driver
[   15.697388] input: Metadot - Das Keyboard Das Keyboard Model S as /devices/pci0000:00/0000:00:15.0/usb1/1-4/1-4:1.0/0003:24F0:0137.0001/input/input2
[   15.756714] hid-generic 0003:24F0:0137.0001: input,hidraw0: USB HID v1.10 Keyboard [Metadot - Das Keyboard Das Keyboard Model S] on usb-0000:00:15.0-4/input0
[   15.756954] input: Metadot - Das Keyboard Das Keyboard Model S as /devices/pci0000:00/0000:00:15.0/usb1/1-4/1-4:1.1/0003:24F0:0137.0002/input/input4
[   15.816631] hid-generic 0003:24F0:0137.0002: input,hidraw1: USB HID v1.10 Device [Metadot - Das Keyboard Das Keyboard Model S] on usb-0000:00:15.0-4/input1
[   15.816846] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:15.0/usb1/1-6/1-6:1.0/0003:046D:C526.0003/input/input5
[   15.817305] hid-generic 0003:046D:C526.0003: input,hidraw2: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:15.0-6/input0
[   15.817559] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:15.0/usb1/1-6/1-6:1.1/0003:046D:C526.0004/input/input6
[   15.876367] hid-generic 0003:046D:C526.0004: input,hiddev0,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:15.0-6/input1
[   16.700982] scsi 1:0:0:0: Direct-Access     Flash    USB Disk         6.80 PQ: 0 ANSI: 2
[   29.558638] usbcore: registered new interface driver btusb
[   57.596571] usb 1-6: USB disconnect, device number 4
[   61.620201] usb 1-5: new full-speed USB device number 6 using xhci_hcd
[   61.771234] usb 1-5: New USB device found, idVendor=046d, idProduct=c526
[   61.771241] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   61.771245] usb 1-5: Product: USB Receiver
[   61.771249] usb 1-5: Manufacturer: Logitech
[   61.774585] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:15.0/usb1/1-5/1-5:1.0/0003:046D:C526.0005/input/input20
[   61.775730] hid-generic 0003:046D:C526.0005: input,hidraw2: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:15.0-5/input0
[   61.777994] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:15.0/usb1/1-5/1-5:1.1/0003:046D:C526.0006/input/input21
[   61.837084] hid-generic 0003:046D:C526.0006: input,hiddev0,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:15.0-5/input1
[   67.860083] usb 1-6: new high-speed USB device number 7 using xhci_hcd
[   67.988100] usb 1-6: device descriptor read/64, error -71
[   68.224163] usb 1-6: device descriptor read/64, error -71
[   68.460053] usb 1-6: new high-speed USB device number 8 using xhci_hcd
[   68.588043] usb 1-6: device descriptor read/64, error -71
[   68.824058] usb 1-6: device descriptor read/64, error -71
[   68.932152] usb usb1-port6: attempt power cycle
[   69.584096] usb 1-6: new high-speed USB device number 9 using xhci_hcd
[   69.584215] usb 1-6: Device not responding to setup address.
[   69.792441] usb 1-6: Device not responding to setup address.
[   70.000086] usb 1-6: device not accepting address 9, error -71
[   70.128044] usb 1-6: new high-speed USB device number 10 using xhci_hcd
[   70.128133] usb 1-6: Device not responding to setup address.
[   70.336262] usb 1-6: Device not responding to setup address.
[   70.544043] usb 1-6: device not accepting address 10, error -71
[   70.544146] usb usb1-port6: unable to enumerate USB device
[   92.704130] usb 1-6: new high-speed USB device number 11 using xhci_hcd
[   92.832154] usb 1-6: device descriptor read/64, error -71
[   93.068044] usb 1-6: device descriptor read/64, error -71
[   93.304033] usb 1-6: new high-speed USB device number 12 using xhci_hcd
[   93.432272] usb 1-6: device descriptor read/64, error -71
[   93.668114] usb 1-6: device descriptor read/64, error -71
[   93.776182] usb usb1-port6: attempt power cycle
[   94.428111] usb 1-6: new high-speed USB device number 13 using xhci_hcd
[   94.428257] usb 1-6: Device not responding to setup address.
[   94.636329] usb 1-6: Device not responding to setup address.
[   94.844129] usb 1-6: device not accepting address 13, error -71
[   94.976032] usb 1-6: new high-speed USB device number 14 using xhci_hcd
[   94.976148] usb 1-6: Device not responding to setup address.
[   95.184118] usb 1-6: Device not responding to setup address.
[   95.392000] usb 1-6: device not accepting address 14, error -71
[   95.392096] usb usb1-port6: unable to enumerate USB device


Mon Nov 05, 2018 12:39 am
Profile
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 384
Post Re: USB ports not functioning
What is the machine's BIOS version?
It is worth trying to flash a new BIOS if you do not have the latest.
Please visit:
http://fit-pc.com/wiki/index.php/Fitlet2:_BIOS_Update

Please follow the procedure documented at the link above in order to update the machine's firmware.


Tue Nov 06, 2018 8:17 am
Profile

Joined: Sat Nov 03, 2018 4:28 pm
Posts: 4
Post Re: USB ports not functioning
I upgraded the BIOS firmware from 0.40 to 0.46 successfully. Front USB ports are still not working however. dmesg below:

Code:
[    0.000000] ACPI: SSDT 0x0000000079E24420 001084 (v02        UsbCTabl 00000003 BRXT 0100000D)
[    0.185626] ACPI: bus type USB registered
[    0.185626] usbcore: registered new interface driver usbfs
[    0.185626] usbcore: registered new interface driver hub
[    0.185626] usbcore: registered new device driver usb
[    1.997265] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    1.997316] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    1.997347] uhci_hcd: USB Universal Host Controller Interface driver
[    1.997758] xhci_hcd 0000:00:15.0: new USB bus registered, assigned bus number 1
[    1.999147] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.999150] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.999153] usb usb1: Product: xHCI Host Controller
[    1.999156] usb usb1: Manufacturer: Linux 4.15.0-38-generic xhci-hcd
[    1.999159] usb usb1: SerialNumber: 0000:00:15.0
[    1.999465] hub 1-0:1.0: USB hub found
[    2.001087] xhci_hcd 0000:00:15.0: new USB bus registered, assigned bus number 2
[    2.001095] xhci_hcd 0000:00:15.0: Host supports USB 3.0  SuperSpeed
[    2.001171] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003
[    2.001174] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.001177] usb usb2: Product: xHCI Host Controller
[    2.001179] usb usb2: Manufacturer: Linux 4.15.0-38-generic xhci-hcd
[    2.001182] usb usb2: SerialNumber: 0000:00:15.0
[    2.001443] hub 2-0:1.0: USB hub found
[    2.336037] usb 1-3: new high-speed USB device number 2 using xhci_hcd
[    2.490866] usb 1-3: New USB device found, idVendor=058f, idProduct=6387
[    2.490870] usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.490872] usb 1-3: Product: Mass Storage
[    2.490874] usb 1-3: Manufacturer: Generic
[    2.490875] usb 1-3: SerialNumber: 3680B8B1
[    2.616089] usb 1-4: new low-speed USB device number 3 using xhci_hcd
[    2.776133] usb 1-4: New USB device found, idVendor=24f0, idProduct=0137
[    2.776136] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    2.776138] usb 1-4: Product: Das Keyboard Model S
[    2.776140] usb 1-4: Manufacturer: Metadot - Das Keyboard
[    2.916196] usb 1-8: new full-speed USB device number 4 using xhci_hcd
[    3.066191] usb 1-8: New USB device found, idVendor=8087, idProduct=0a2b
[    3.066195] usb 1-8: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    3.073912] usb-storage 1-3:1.0: USB Mass Storage device detected
[    3.074634] scsi host1: usb-storage 1-3:1.0
[    3.074787] usbcore: registered new interface driver usb-storage
[    3.077090] usbcore: registered new interface driver uas
[    3.096471] usbcore: registered new interface driver usbhid
[    3.096474] usbhid: USB HID core driver
[    3.100142] input: Metadot - Das Keyboard Das Keyboard Model S as /devices/pci0000:00/0000:00:15.0/usb1/1-4/1-4:1.0/0003:24F0:0137.0001/input/input2
[    3.160454] hid-generic 0003:24F0:0137.0001: input,hidraw0: USB HID v1.10 Keyboard [Metadot - Das Keyboard Das Keyboard Model S] on usb-0000:00:15.0-4/input0
[    3.160674] input: Metadot - Das Keyboard Das Keyboard Model S as /devices/pci0000:00/0000:00:15.0/usb1/1-4/1-4:1.1/0003:24F0:0137.0002/input/input3
[    3.220212] hid-generic 0003:24F0:0137.0002: input,hidraw1: USB HID v1.10 Device [Metadot - Das Keyboard Das Keyboard Model S] on usb-0000:00:15.0-4/input1
[    5.809214] usbcore: registered new interface driver btusb
[   21.092807] usb 1-3: USB disconnect, device number 2
[   27.676175] usb 1-3: new high-speed USB device number 5 using xhci_hcd
[   27.824383] usb 1-3: New USB device found, idVendor=0409, idProduct=005a
[   27.824391] usb 1-3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[   27.825340] hub 1-3:1.0: USB hub found
[   36.180078] usb 1-3.1: new full-speed USB device number 6 using xhci_hcd
[   36.283128] usb 1-3.1: New USB device found, idVendor=046d, idProduct=c526
[   36.283132] usb 1-3.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   36.283134] usb 1-3.1: Product: USB Receiver
[   36.283136] usb 1-3.1: Manufacturer: Logitech
[   36.287523] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:15.0/usb1/1-3/1-3.1/1-3.1:1.0/0003:046D:C526.0003/input/input12
[   36.287913] hid-generic 0003:046D:C526.0003: input,hidraw2: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:15.0-3.1/input0
[   36.289932] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:15.0/usb1/1-3/1-3.1/1-3.1:1.1/0003:046D:C526.0004/input/input13
[   36.350684] hid-generic 0003:046D:C526.0004: input,hiddev0,hidraw3: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:15.0-3.1/input1
[   50.784112] usb 1-6: new high-speed USB device number 7 using xhci_hcd
[   50.912731] usb 1-6: Device not responding to setup address.
[   51.121278] usb 1-6: Device not responding to setup address.
[   51.329567] usb 1-6: device not accepting address 7, error -71
[   51.457879] usb 1-6: new high-speed USB device number 8 using xhci_hcd
[   51.586682] usb 1-6: Device not responding to setup address.
[   51.795107] usb 1-6: Device not responding to setup address.
[   52.003203] usb 1-6: device not accepting address 8, error -71
[   52.003319] usb usb1-port6: attempt power cycle
[   52.656703] usb 1-6: new high-speed USB device number 9 using xhci_hcd
[   52.656966] usb 1-6: Device not responding to setup address.
[   58.013913] usb 1-6: device descriptor read/all, error -110
[   58.913962] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[   58.914044] usb usb1-port6: unable to enumerate USB device
[   76.455660] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[   77.355645] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[   77.355740] usb usb1-port6: attempt power cycle
[   78.571671] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[   79.471657] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[   79.471763] usb usb1-port6: unable to enumerate USB device
[   91.787696] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[   92.687679] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[   92.687791] usb usb1-port6: attempt power cycle
[   93.903675] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[   94.803693] usb usb1-port6: Cannot enable. Maybe the USB cable is bad?
[   94.803813] usb usb1-port6: unable to enumerate USB device


Wed Nov 07, 2018 12:34 am
Profile

Joined: Tue Jul 24, 2018 8:37 am
Posts: 29
Post Re: USB ports not functioning
after reading this topic carefully, I wonder if you did install the specific Intel firmware.
another point is the kernel you use.

I am running Debian 9.5 which has a much older kernel.
but all usb-ports are working.
may be you could prepare a bootable usb-stick with Debian and see where it gets you.


Wed Nov 07, 2018 5:54 pm
Profile

Joined: Sat Nov 03, 2018 4:28 pm
Posts: 4
Post Re: USB ports not functioning
Fred: I don't understand what you're suggesting here...

Tamir: What else can we try before we say it's definitely a hardware issue?


Fri Nov 09, 2018 2:56 am
Profile
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 384
Post Re: USB ports not functioning
SEC wrote:
Fred: I don't understand what you're suggesting here...

Tamir: What else can we try before we say it's definitely a hardware issue?


I'd suggest as last thing to install Windows 10 on the machine.
If the behavior remains the same, then please RMA this machine.

The RMA procedure is documented at the following link:
http://www.fit-pc.com/web/support/rma/


Sun Nov 11, 2018 8:06 am
Profile

Joined: Tue Jul 24, 2018 8:37 am
Posts: 29
Post Re: USB ports not functioning
SEC wrote:
Fred: I don't understand what you're suggesting here...


I have Debian 9 with LXDE running.
may be you could install that, just in order to check the USB-ports.


Sun Nov 11, 2018 9:21 am
Profile

Joined: Wed May 01, 2019 2:44 pm
Posts: 1
Post Re: USB ports not functioning
Did you ever find a solution to this issue? I am actually experiencing a similar problem. I have 2 identical fitlet2, and one of them had functionnal front USB3 ports (I used them to plug a keyboard and change settings in the BIOS and install the OS with a USB key). A few days later however, the ports do not work at all (even in the BIOS).

I tried powering it off, let it cool down, etc, but no luck in bringing them back up.

Thank you!


Wed May 01, 2019 2:51 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.