View unanswered posts | View active topics It is currently Sat Dec 14, 2019 1:25 pm



Reply to topic  [ 6 posts ] 
 Win10 (64bit) driver for serial ports (Fitlet2 Atom-E3930) 
Author Message

Joined: Thu Jan 25, 2018 4:04 pm
Posts: 3
Post Win10 (64bit) driver for serial ports (Fitlet2 Atom-E3930)
Hello,
where can I find a driver for the serial port (COM1) for Window10 64 bits for the Fitlet2 Atom-E3930.
Actually, after windows has performed all updates, device manager still shows "unkown devices".

Regards,
Andi


Thu Jan 25, 2018 4:09 pm
Profile
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 386
Post Re: Win10 (64bit) driver for serial ports (Fitlet2 Atom-E393
You should find Windows 10 drivers at the below link:

http://fit-pc.com/wiki/index.php/Fitlet ... Windows_10


Sun Jan 28, 2018 3:28 pm
Profile

Joined: Thu Jan 25, 2018 4:04 pm
Posts: 3
Post Re: Win10 (64bit) driver for serial ports (Fitlet2 Atom-E393
Hello Tamir,
thanks for replay.

I set up the Fitlet2 Atom-E3930 with win10 using the "MediaCration-Tool".
As recommended by you, I installed the fitlet2_Win10_Chipset as well as the fitlet2_Win10_SerialIO.

But it doesn't help. Device manager still shows "unkown devices". There is still no COM-Port shown in device manager.
Also the power button seem to have no effect if it gets pressed only short. Windows is not shut down.

Any further recommendations?

Regards Andi


Mon Jan 29, 2018 11:44 am
Profile

Joined: Wed Jan 31, 2018 1:13 pm
Posts: 3
Post Re: Win10 (64bit) driver for serial ports (Fitlet2 Atom-E393
Bootup.
Its work for me. :? Il try search solution for you.Later.


Wed Jan 31, 2018 1:54 pm
Profile

Joined: Thu Nov 25, 2010 10:50 pm
Posts: 2
Post Re: Win10 (64bit) driver for serial ports (Fitlet2 Atom-E393
I'm having similar problems with the Fitlet2. I can't get it work on a fresh Win10 home install with either the drivers on the website or the drivers obtained from Windows Update.

Here's what happens when I install the latest drivers directly from the Fit-PC website. The UART controller drivers do not start, and the sub-devices are not even detected.
Attachment:
File comment: Result of installing drivers directly from Fit-PC website
Fitlet2ComPortSiteDrivers.png
Fitlet2ComPortSiteDrivers.png [ 82.74 KiB | Viewed 1552 times ]


If I let Windows Update detect the device instead, it installs a completely different driver. These drivers appear to start, but I still need to install the sub-device driver from the Fit-PC website before the COM Ports appear in device manager.
Attachment:
File comment: What is detected in Windows Update
Fitlet2ComPortWindowsUpdate.png
Fitlet2ComPortWindowsUpdate.png [ 194.93 KiB | Viewed 1552 times ]


When I combine the two, device manager looks happy. However, it's not possible to open either COM port in PuTTY. I have other software that detects both ports as "COM 0", despite being listed as COM1 and COM2 in device manager.
Attachment:
File comment: UART drivers from Windows Update, Sub-device drivers from Fit-PC website.
Fitlet2ComPortSubDevice.png
Fitlet2ComPortSubDevice.png [ 86.83 KiB | Viewed 1552 times ]


Note the "on Host Controller 5AC0" on the sub-device, which clearly links it to the UART controller pulled through Windows update. It's also concerning that two serial ports are detected when there only appears to be one implemented in hardware.

This is using the sub-device driver that was uploaded to the website on Friday (2018-08-17). All other device drivers on the system are installed and operational (Chipset, TXE etc.). It doesn't seem to make a difference if the other drivers come from Windows Update or the Fit-PC website (I tried both). Windows 10 Home 1803 was installed using the USB media creation tool.

The two configurations were tried with full HDD wipe and reinstall inbetween. I've also got 4 units here which all exhibit this problem. I don't think it's specific to a single unit.

Update: Just tried Win10 Pro and got exactly the same result.


Mon Aug 20, 2018 3:28 am
Profile
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 386
Post Re: Win10 (64bit) driver for serial ports (Fitlet2 Atom-E393
Please update the UART and UART sub device drivers to the latest:

http://www.fit-pc.com/wiki/index.php/Fi ... Windows_10

After that Please confirm the below:

Enter to the BIOS menu, and set 4G decoding to Disabled:

Advanced > PCI Subsystem > 4G Decoding [Disabled]

The driver has been tested with:

Putty
ExtraPutty
MobaXterm terminals

The driver supports the Hardware and None flow control, but doesn't support the Software (XON/XOFF) flow control.


Mon Aug 20, 2018 8:36 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.