fit-PC Users Forum
https://www.fit-pc.com/forum/

display question
https://www.fit-pc.com/forum/viewtopic.php?f=18&t=1066
Page 1 of 1

Author:  smiguy [ Mon Nov 02, 2009 3:24 pm ]
Post subject:  display question

Hello,

I'm having issues connecting my fit-pc to my Samsung SyncMaster LCD monitor. It appears that the video signal is getting to the LCD, but it immediately goes into low power mode. Using the same cable I can get the video to display on my Samsung CRT television from the fit-pc. Additionally, my LCD is capable of displaying a picture with my DVD player.

So the situation is, I know that the fit-pc is outputting video and that my LCD is capable of receiving dvi video. But when I put the two together nothing.

Here are some ideas that I've thought of and would like some feedback from the community.

1) Upgrade my single link DVI cable to a dual link one. Rational, I think the signal may be stronger.

2) Get the HDFury and convert to a VGA signal.

3) Buy something that can boost the signal.

4) Get another LCD w/DVI and hope it plays nice with the fit-pc.

5) Assume the fetal position.

Author:  AoRaToS [ Mon Nov 02, 2009 10:17 pm ]
Post subject:  Re: display question

I would try another cable first. If you know someone else with a fit-PC2 try that with your TV also to rule out any problems with your fit-PC2 as I read somewhere on the forum something about a problem with the signaling or so, probably rare...Also I've read about similar problems that were solved by using a repeater... I'd suggest borrowing one first before going out and buying things that might not solve your problem...

Author:  irads [ Tue Nov 03, 2009 7:59 am ]
Post subject:  Re: display question

Check if the BIOS settings screen displays OK.
Connect a powered-off fit-PC2 to your display turned-on, power fit-PC2 while pressing 'F2'.
This should display at VGA mode regardless of any handshake between the display and fit-PC2.

Author:  smiguy [ Wed Nov 04, 2009 1:47 am ]
Post subject:  Re: display question

Thanks for the suggestions.

I tried booting to the BIOS screen and still nothing on my Samsung LCD. I did bring my fit-pc into work and was able to get the display working on a Dell LCD.

So something is up with my Samsung....but yet I still get video over DVI with my DVD player.

I think my only hope with the Samsung LCD is an inline repeater to boost the signal.

Author:  dgux [ Fri Mar 26, 2010 2:39 am ]
Post subject:  Re: display question

I can see BIOS and GRUB just fine but nothing from xorg. Any thoughts how how I can get some video on my Philips plasma TV?

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/