View unanswered posts | View active topics It is currently Tue Aug 20, 2019 9:36 am



Reply to topic  [ 5 posts ] 
 Sony TV gives "unsupported signal" (solved, I think) 
Author Message

Joined: Fri Oct 22, 2010 12:26 am
Posts: 83
Post Sony TV gives "unsupported signal" (solved, I think)
When I use my fit-PC2i with my Sony TV via HDMI (the intended display and connection for the fit-PC2i), the Sony TV gives "unsupported signal".

More specifically, with the computer connected to the TV via HDMI, at power on of the computer the TV says "1024x768" and I see the Energy Star / Intel Atom advertising screen and then during boot the TV says "640x480" while the computer shows "Linux Mint 9 . . . ." but later on the TV screen goes blank and the "unsupported signal" message comes up on the TV screen.

(I did not succeed in logging in "blind", which might well have worked, but this is not a long term option anyway.)

When connected via the fit-VGA adapter to the Sony TV (on its VGA input) the whole startup and login process works fine.

(continued...)


Sun Mar 20, 2011 11:02 pm
Profile

Joined: Fri Oct 22, 2010 12:26 am
Posts: 83
Post Re: Sony TV gives "unsupported signal" (solved, I think)
I surmised that the reason for the problem was that once X was running it was attempting to use a setting for graphics output that was not compatible with the TV - so as soon as X started, output was not possible.

Gleaned from another post in this forum, I did

apt-get install read-edid
read-edid | parse-edid

then editted /etc/X11/xorg.conf using some of the output from parse-edid.

Specifically,

In the section headed Section "Monitor" I added the two valid modes that parse-edid displayed as seemingly valid and in the section headed Section "Screen" I added

SubSection "Display"
Modes "1920x1080" "1280x720"
EndSubSection

"1920x1080" and "1280x720" are the (arbitrary) names of the modes defined in the earlier section.


Sun Mar 20, 2011 11:17 pm
Profile

Joined: Fri Oct 22, 2010 12:26 am
Posts: 83
Post Re: Sony TV gives "unsupported signal" (solved, I think)
I hope this helps somebody else but

Be warned: What I know about X and Linux fits (no pun intended) on the back of a postage stamp. I generally have to proceed using brute force and ignorance.


Sun Mar 20, 2011 11:21 pm
Profile

Joined: Fri Oct 22, 2010 12:26 am
Posts: 83
Post Re: Sony TV gives "unsupported signal" (solved, I think)
I noticed there's a typo in the above

Code:
read-edid | parse-edid


should be

Code:
get-edid | parse-edid


Mon Dec 19, 2011 12:17 pm
Profile

Joined: Sat Jan 09, 2010 4:08 am
Posts: 42
Post Re: Sony TV gives "unsupported signal" (solved, I think)
derek wrote:
When I use my fit-PC2i with my Sony TV via HDMI (the intended display and connection for the fit-PC2i), the Sony TV gives "unsupported signal".


If you're using a recent Linux kernel, it will include the gfx_psb module which knows how to set "any" video mode (including the right one), but IIUC that code does not yet know how to read/parse/use the EDID information from your monitor (check the "display driver" forum where there's a discussion about this), so it uses an arbitrary resolution, which might not be to your monitor's taste.


Thu Feb 16, 2012 4:18 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.