View unanswered posts | View active topics It is currently Wed Dec 11, 2019 11:08 pm



Reply to topic  [ 7 posts ] 
 Problem with digital audio 
Author Message

Joined: Sat Apr 03, 2010 4:13 pm
Posts: 15
Post Problem with digital audio
After maybe 10 hours of struggle, I finally managed to install working drivers for the High definition audio device of my FitPC2i.
Maybe it would be a good idea to put these drivers somewhere they can actually be found instead of posting a link in some thread in this forum.

Actually, the driver installation did not work properly. If I run the setup exetutable an error message appears and the installation closes. The only way of installing the driver is to right click and select "Update driver..." in the device manager.

Anyway... I only get analog audio through the 3.5mm connector market S/PDIF. If I open the IDT control panel there is a checkbox used for activating digital audio out, but nothing changes. If I connect a cable from the 3.5mm socket to an analog input, I get signal, but if I connect it to my DAC nothing happens. I have also checked the signal with a digital oscilloscope and cannot see that there is a digital signal available.

Irads wrote in another thread:
In the pilot batch an IDT codec is used. This is going to change to ALC662 in April-May timeframe.
What about the mentioned pilot batch? Is the S/PDIF really working in these devices?

My OS is Windows XP Pro En with SP3.


Sun Apr 04, 2010 11:52 am
Profile

Joined: Sat Apr 03, 2010 4:13 pm
Posts: 15
Post Re: Problem with digital audio
More information.

Driver installation
When trying to install the audio drivers, this dialog shows:
Image

The detailed information is:
Code:
Error Code:   -5009 : 0x80040806
Error Information:
>Kernel\IScriptWrapper.cpp (19)
>Kernel\ObjectWrapper.cpp (162)
>Kernel\ObjectWrapper.cpp (557)
>Kernel\Component.cpp (1179)
>Kernel\CABFile.cpp (425)
>SetupNew\setup.cpp (856)
PAPP:IDT
PVENDOR:IDT (http://www.idt.com)
PGUID:E3A5A8AB-58F6-45FF-AFCB-C9AE18C05001
$14.0.0.162
@Windows XP Service Pack 3 (2600)  Non IE/Netscape 61608.19


S/PDIF output problem
So... I managed to install the driver anyway (but maybe incorrectly?).
It makes not difference whether I check the SPDIF Interface checkbox or not - I only get analogue audio.
Image

Just to verify; Is there some kind of special connector for the S/PDIF output? I have a cable that worked to connect my Soundblaster Audigy to the DAC (3.5mm mono to 1xRCA).


Sun Apr 04, 2010 12:07 pm
Profile

Joined: Sun Mar 22, 2009 2:49 pm
Posts: 539
Location: Israel
Post Re: Problem with digital audio
linusn wrote:
Just to verify; Is there some kind of special connector for the S/PDIF output? I have a cable that worked to connect my Soundblaster Audigy to the DAC (3.5mm mono to 1xRCA).

You need a coaxial SPDIF cable to utilize digital output. I could not really understand what cable are you using now?


Mon Apr 05, 2010 5:49 pm
Profile WWW

Joined: Sat Apr 03, 2010 4:13 pm
Posts: 15
Post Re: Problem with digital audio
I used a coaxial SPDIF cable of course (3.5mm mono to 1xRCA).


Mon Apr 05, 2010 7:48 pm
Profile

Joined: Sun Mar 22, 2009 2:49 pm
Posts: 539
Location: Israel
Post Re: Problem with digital audio
I'm not sure whether your cable is the same as Compulab would supply in new orders (it was not supplied with pilot batch). You should try to acquire Compulab stock cable from one of the distributors to make sure that your cable is not a problem.


Mon Apr 05, 2010 8:16 pm
Profile WWW
Site Admin

Joined: Mon Mar 16, 2009 2:11 pm
Posts: 2348
Post Re: Problem with digital audio
The S/PDIF cable is a custom 3.5mm jack with 3 rings - to RCA.
It is on the parts list of the pilot batch and should be included in the package. Please check again that it is included.
If it is missing email sales@compulab.co.il

S/PDIF will not work with a standard 3.5mm to RCA cable.

_________________
-------------------------
Irad Stavi
fit-PC forum admin

-------------------------


Tue Apr 06, 2010 8:38 am
Profile

Joined: Sat Apr 03, 2010 4:13 pm
Posts: 15
Post Re: Problem with digital audio
Ok. This was not included in my package. I'll email...


Tue Apr 06, 2010 9:04 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.