View unanswered posts | View active topics It is currently Mon Dec 09, 2019 2:02 am



Reply to topic  [ 6 posts ] 
 fit-pc2i fails to boot, no video, power light is on 
Author Message

Joined: Thu Jun 23, 2011 9:06 pm
Posts: 18
Post fit-pc2i fails to boot, no video, power light is on
Hi guys,

I notice that after pressing the power button, the power green light indicate that fitpc2i (fit-PC2-D2G-C1600-W with WIFI) is on but I did not get any video signal to the monitor, no indication that the keyboard is detected and the Mint OS does not boot.

A few days ago, there was a power-shortage and I noticed that my BIOS settings were reset to defaults, as well as the system time. So, I suspect that there is a problem with my on-board battery and loosing the default BIOS settings.

I tried without success:
- removing the HDD
- booting from external flash
- left it on-power for 12h to charge the on-board battery

So, is there a way how to reset the BIOS settings? or if this is not the problem, how shall I proceed?

PS: My fitpc behaviour seems to be the same as this one: viewtopic.php?f=37&t=1725

I have already written to rma@fit-pc.com as well.


Sat Jan 18, 2014 10:02 am
Profile
Post Re: fit-pc2i fails to boot, no video, power light is on
If you experience boot issues, please consider to RMA the unit, and follow RMA procedure. There might be damaged components after the voltage surge. BIOS settings are not really matters if you cannot boot.
http://www.fit-pc.com/web/support/rma/


Mon Jan 20, 2014 12:32 pm

Joined: Thu Jun 23, 2011 9:06 pm
Posts: 18
Post Re: fit-pc2i fails to boot, no video, power light is on
Thanks for the reply,

eventually I managed to boot the fit-pc successfully with default BIOS configuration.

Unfortunately, the previously described problem appeared again after the fit-pc was disconnected from the power grid for a few days. It looks to me that the on-board battery is defected.

So, is there any easy way to test or replace it? I noticed that it is Li-on and it is soldered to board.


Sat Feb 01, 2014 6:34 pm
Profile
Post Re: fit-pc2i fails to boot, no video, power light is on
The CMOS battery is indeed soldered onboard and it is a rechargeable battery, but please note it does not responsible for boot, but for RTC block only - to keep Time and BIOS settings). You must be able to boot even without the battery, but with BIOS settings reseted.
In order to guarantee that the battery is fully charged please plug it for 24 hours to a power source, and leave it in BIOS screen (to ensure no low power states).
If you will still experience boot issues, please RMA the unit.
http://www.fit-pc.com/web/support/rma/


Sun Feb 02, 2014 2:11 pm

Joined: Thu Jun 23, 2011 9:06 pm
Posts: 18
Post Re: fit-pc2i fails to boot, no video, power light is on
Thanks for the proposal, but charging it does not do the job.

I am in touch with the RMA team to resolve the problem.


Mon Feb 10, 2014 3:21 pm
Profile

Joined: Thu Jun 23, 2011 9:06 pm
Posts: 18
Post Re: fit-pc2i fails to boot, no video, power light is on
Eventually the problem was caused by the CMOS battery.

I would like to thanks a lot for the excellent out-of-warranty service that compulab provided.

In case, somebody has a similar problem, I would suggest to buy a new battery rather than sending it to Israel, because the import/export taxes + shipping cots to/from EU are quire high, close to the price of new unit. Cheers!

:mrgreen:


Wed Apr 23, 2014 8:43 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.