fit-PC Users Forum
https://www.fit-pc.com/forum/

Problem with PCI Device and AVR309 USB to UART convertor
https://www.fit-pc.com/forum/viewtopic.php?f=45&t=1898
Page 1 of 1

Author:  mandaPanda [ Wed Sep 15, 2010 12:44 pm ]
Post subject:  Problem with PCI Device and AVR309 USB to UART convertor

Hi, I have recently brought a fit-pc2, due to software issues I have 'downgraded' to Windows XP, after installation I installed the drivers from the fit-pc download page - wi-fi, ethernet, chipset etc, with no problems. however I have an error in the Device Manager, under Other Devices, PCI Device and AVR309 USB to UART convertor protocol are listed with the yellow question mark and exclaimation mark, when I go to properties I get the following message in Device status: The drivers for this device are not installed. (Code 28), I have tried to install the drivers - using windows update yet no drivers are found.

Does anyone know how this issue can be resolved or where I can download the correct drivers from? Thanks in advance.

Author:  mandaPanda [ Wed Sep 15, 2010 12:56 pm ]
Post subject:  Re: Problem with PCI Device and AVR309 USB to UART convertor

Update:
Hi, I have fixed the AVR 309 issue by downloading the ir driver (one of the only ones I hadn't already done!) and finaly convincing windows to let me select the driver myself - however the PCI problem persists!

Author:  Leonid [ Wed Sep 15, 2010 4:49 pm ]
Post subject:  Re: Problem with PCI Device and AVR309 USB to UART convertor

Hi.

Please, provide the Device Instance ID.
This will help us to identify what is the device.

Author:  mandaPanda [ Sat Sep 18, 2010 8:49 pm ]
Post subject:  Re: Problem with PCI Device and AVR309 USB to UART convertor

I have looked up the device Id, the vendor is Intel (8086) and the device id is 811B, which I believe maybe to do with the ethernet connections? Someone has suggested that as the fit pc2 and fit pc2i share the same image and the pc2i has 2 connections for ethernet (where the pc2 has 1) it could be that windows thinks there should be another ethernet device/driver and can't find it so reports and unknown PCI device - does this seem likely?

The full hardware id is:

PCI\VEN_8086&DEV811B&SUBSYS_8119806&119086&REV_07

Thanks, any suggestion will be gratefully recieved!

Author:  fly [ Sat Sep 18, 2010 11:29 pm ]
Post subject:  Re: Problem with PCI Device and AVR309 USB to UART convertor

FitPC2 and 2i share quite some bits, but Windows does not simply assume there might be another ethernet controller, when there isn't. The mini-pcie slot on the fitPC2 is populated with a WLAN card (when WLAN option is selected), on fitPC2 those resource were used for a secondary ethernet controller (and a usb-wlan chip).

The information identifies the part as:
Quote:
# vendor: 8086 ("Intel Corporation"), device: 811b ("System Controller Hub (SCH Poulsbo) HD Audio Controller")

Quote:
Microsoft UAA Bus Driver for High Definition Audio

Author:  Leonid [ Sun Sep 19, 2010 9:38 am ]
Post subject:  Re: Problem with PCI Device and AVR309 USB to UART convertor

Quote:
PCI\VEN_8086&DEV_811B&SUBSYS_81198086&REV_07\3&B1BFB68&0&D8
Name: Microsoft UAA Bus Driver for High Definition Audio
Hardware ID's:
PCI\VEN_8086&DEV_811B&SUBSYS_81198086&REV_07
PCI\VEN_8086&DEV_811B&SUBSYS_81198086
PCI\VEN_8086&DEV_811B&CC_040300
PCI\VEN_8086&DEV_811B&CC_0403


Microsoft UAA Bus Driver for High Definition Audio is part of SP3. Did you install it?

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/