View unanswered posts | View active topics It is currently Mon Jun 17, 2019 12:33 pm

Reply to topic  [ 6 posts ] 
 Windows 10 on IPC2 
Author Message

Joined: Thu Sep 17, 2015 8:43 am
Posts: 21
Post Windows 10 on IPC2
Hi. I want to install Win10-pro-64bit on an IPC2. Did you try it? Should I expect any trouble?

Thu Sep 17, 2015 8:47 am
Site Admin

Joined: Mon Mar 16, 2009 2:11 pm
Posts: 2335
Post Re: Windows 10 on IPC2
Win10 should install with no major issues on IPC2. Please be advised that Compulab does not support it officially yet and we did not run rigorous tests on Windows 10, so we cannot offer support in case you encounter problems. That said, the likelihood of major problems is low.

Irad Stavi
fit-PC forum admin


Fri Sep 18, 2015 3:38 pm

Joined: Thu Sep 17, 2015 8:43 am
Posts: 21
Post Re: Windows 10 on IPC2
I installed Win10 Pro on IPC2 with no issues late 2015. During pilot tests the IPC2 intermittently lost contact with one of the ethernet ports. The port had be disabled / reenabled or the PC had to be restarted to regain contact. I had no luck solving it with Driver updates from Intel. I had to drop the project for a while but in a few weeks I will restart the tests.

This may have absolutely nothing to do with the IPC2 but I would like to hear if anyone else has seen the problem or perhaps solved it.

Fri Jan 29, 2016 8:36 am
Post Re: Windows 10 on IPC2
Please let us know what drivers have you been using?
I will forward it to our Windows expert.

Wed Feb 03, 2016 10:48 am

Joined: Sun Apr 26, 2009 5:10 pm
Posts: 157
Post Re: Windows 10 on IPC2

1. Please, provide us the SN and PN of your IPC2.

2. What Ethernet controller lose connection? i211 or i218?

3. When connection is lost, do you see the Ethernet controller in the Device Manager?

Leonid Firdman

Mon Feb 15, 2016 2:30 pm

Joined: Thu Sep 17, 2015 8:43 am
Posts: 21
Post Re: Windows 10 on IPC2

Sorry about this late reply. The issue is still there on the 12 unmanned Win10-1511-IPC2s that I have sent out. These systems are extremely stable and the problem is manageable. The issue is shurely caused by Microsoft/Intel/Firewall rather than Compulab hardware.

The issue arises in the Intel-218 on Win10-startup. The Ethernet port is still apparently up but I loose connection to some UDP-ports in the range 6000:6208. I can fix it by taking down the Ethernet-switch or disable+enable the Ethernet port in Windows. On each startup I run this Powershell script that takes down and up the port automatically before starting the program.

#Take the network down and up to avoid weird network trouble (some ip/ports will not work)
Get-NetAdapter -name camnet | Disable-NetAdapter -Confirm:$false
Get-NetAdapter -name camnet | Enable-NetAdapter -Confirm:$false
sleep 4

1. Example:
SN: 1160114-05035

2. i218

3. I think it was visible in the Device Manager. I should have noticed if it was gone. I will check it but it may be a while.

4. I use the This is the most recent driver that Intel released Powershell management for. I am aware that a driver update may solve this issue but I really need the management.

Fri Dec 16, 2016 7:21 am
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.