View unanswered posts | View active topics It is currently Sat Aug 24, 2019 5:32 pm

Reply to topic  [ 9 posts ] 
 My Research EVSA out of Space & ? Engineer 
Author Message

Joined: Wed Aug 29, 2012 12:18 am
Posts: 67
Post My Research EVSA out of Space & ? Engineer
First, I can make and delete boot menu entries with no issue.

Second, UEFI v3 worked fine before messed the PC by reverting to v2.

Third I can boot the machine. It just auto powers off after a time instantly. Maybe temp sensor trip points messed up with all this.

Forth the PC won't flash to v3, v4 or v5. becuase of the ESVA out of space issue (exhausted).

EVSA = EFI variable storage area,

Ok let take trouble shooting to a higher level in todays attempt. Lets use Ubuntu FWTS v18.05 Live.

Make a USB nand flash stick with it and boot into it.
about and exit to command prompt.

sudo -s
fwts uefivarinfo -

On my IntensePC
UEFI NVRAM storage
Maximum storage 57324 bytes (So Primary area is 56K in size)
Remaining storage is 41742 bytes (Way more than half)
Maximum variable size 8152 bytes
Current used
88 variables, storage used 7491 bytes
So: 15,582 bytes is really been used up here
8,091 could be free'd up if garbage collection was run.
Maybe garbage collection routine engages at 50% remaining point
57324/2 = 28,662 bytes.
I did a:
fwts uefirtvariable
fwts uefirtvariable--uefi-set-var=10000

Both should have consumed more remaining space. But funny thing there it did not. The goal is to use up 50% of the space and try to engage garbage collection (UEFI Fault Tolerant Write protocol ) on next boot. But the space used remained the same. Very Strange.

I rebooted to windows. Used EasyUEFI and created a boot menu entry for MEMtest86+. Then rebooted back into FWTS.

The remainng space changed to 41574 bytes used. and 89 variables with 7623 bytes used in total by the variables. Ok, one boot entry used 168 bytes. So, I could create and delete the entry 78.85 times to use up 50% of the space. A lot of work. Maybe I can write a AutoIt script to do it in a few seconds.

But something wacky here?
The EVSA space is not really exhausted here. the SPI chip is not broken in that regard. It just looks like needs a large amount of EVSA space to be free for the Flash process be allowed to go through. The question is why.

The Cap file is 4067KB. There no way that is wriitten into the EVSA space.
So I assume the process is writing variables there and needs a huge amount of free space for the fault tolerate process. Else maybe there a special seperate area for the CAP file that's full here. And the error is wacko.

But dam i'm 72% free. How free does the space need to be here.

Fit-Pc/Compu Lab Bios Engineer a few question?

1/ To flash the UEFI Firmware, how much EVSA remaining space must we have free? 49K? (Note: that is bit stupid if so)

2/ At what % of remaing space does the automatic garbage routine (UEFI Fault Tolerant Write protocol) engage and free up the deleted space to the remaining available pool?

Thu Jun 07, 2018 12:04 am

Joined: Wed Aug 29, 2012 12:18 am
Posts: 67
Post Re: My Research EVSA out of Space & ? Engineer
Hmm! things did not work out the way I was thinking here.

Using EasyUEFI I created and deleted 80 boot entries that should eaten 168 bytes each. and half the EVSA (EFI Variable storage area).

However rebooting into "FWTS Live v18.05 "showed remaining space only went from 41574 to 41300. With 91 variables using 8138 in space.

Last week I had 41574 remaing in 88 variable using 8152bytes.
Now Have 3 more variables somehow. and we didn't use up half the space as expected.

I went back into windows and EasyUEFI and create 5 boot variables, rebooted to FWTS. "FWTS UEFIVARINFO -" showed the remaing space decreased to 40630. so that 74bytes per entry. Went back in windows and EasyUEFI deleted the variables and then went back FWTS. UEFIVARINFO show the remaining space went back to 41300.

I did not expect that. If the NVRAM can only write a 0 and not a 1 then the delete should only flag as deleted but not free it up space. Thus you should only decrease in available space until finally hitting 50% used mark where the garbage collection kicks in.
But FWTS showed I got the space used right back on the deletion of variable here. Odd???

I also noticed the reboot process is now working right after the 80 created and then deleted variables. and also so far the pc hasn't auto instant shutdown on me. hmm?? weird why is that working now. I'm going the let the pc run all night and check if it still running in the morning.

This brings up questions on shellflash64.efi here. If "/cvar" is used, that deletes the EFI variables (I do in fact lose the boot entries on reboot using it). Does that mean I get more free space back by using it?

Now I've done /cvar before it did not help me. But when I added /v switch, it showed me I was getting the "EVSA Region Exhausted" error here.

With the /cvar switch it just rebooted the machine in 5sec and the flash didn't go through. You didn't know why. Maybe it checks the free space before deleting the variables. (That would be design Flaw)

But the key thing is the machine did a reboot and recreated the most of variables /cvar deleted ( except: the windows, Linux, and refind entries) That means should then retaken a bunch of that free space back a that reboot.

And maybe that's disconnect here and the trick. Maybe we have and do should a two part process here. First do "/cvar /v" first. That would clear all the variables but not reboot the pc. It would still error out because it maybe checks free space first but does do the /cvar and clears variables. Maybe the variables will all be deleted and won't be recreate because with "/v" it doesn't reboot. That might give you maximum free variable space at that moment.

Then do the normal "shellflash64.efi /file Bios.cap". Maybe then it will see enough free space on the EVSA space check and flash UEFI.

After a flash it auto reboots the machine 5sec later. recreating most the missing default variables on the reboot. Leaving you to create the windows, Linux, refind entries. which is easy if had refind installed or even if its just on a usb key because you can drop in shell64.efi and launch windows directly by running refind64.efi. Once Windows runs up it replaces its missing boot entry automatically and as does Linux. linux also replaces them with each kernel update too over time via each kernel update.

This is my current working theory here. I'll have to this try out in another day or so and report back.

Tue Jun 12, 2018 2:16 am

Joined: Wed Aug 29, 2012 12:18 am
Posts: 67
Post Re: My Research EVSA out of Space & ? Engineer
no go

seems /cvar /v doesn't clear the variables like /patch /cvar does.

Know /cvar /patch does clear the variables but also bumps you out of UEFI mode. So must go turn it back on to get the shell or the drives. Then Windows boot entry is automatically regenerated.

so it must error out first before /cvar for lack of space.

I tried /capload that does successfully report the load of the bios.cap file into the cap memory space. But doesn't perform the update. ? as why you what to do that.

Tried /force too. but no go

Outside of creating 80 boot entries with out deleting them and rebooting the booting back into windows and then deleting them. I don't know what else I can try.

Again fo the engineer Why is a Firmware update check the EVSA space in the first place here. If /capload can successfully load the cap file into the memory. It not that memory space that is an issue.

Maybe I should go get the "Hades Canyon's" as an replacement

Wed Jun 13, 2018 12:27 am

Joined: Wed Aug 29, 2012 12:18 am
Posts: 67
Post Re: My Research EVSA out of Space & ? Engineer
Well I used a online character generator to randomly gen up 400 characters. I then used EasyUEFI to create 23 new boot entries point to MemTest86.EFI. For I select the option Unicode text option and Pasted the 400 characters into it, previewed it.

This result in consuming more 50% of the free variable space. Again the goal was to have Garbage Collection routine in Tiano enage the Fault tolerant write protocol and free up the lock and deleted space to reclaim it.

Result: No go. The PC would do what looked like numerous power on and off while not booting up. Then after awhile it boot up.

Maybe I need to consume more or the mechanism is just broken. I delete the variable. Reclaiming most the space I used up in process. But now powering off on repeatedly for long while before booting up now. Last I had not to boot issue but went away after playing with FWTS testing.

Intense still boots up and stays on. But its still not right.
Still leaning toward buying the new NUC8 now. Quad core with real graphics plus thunderbolt. The thunder 10G Lan adapter would be possible with that. But it 190W machine. vis 15-18W. BUt it would have power.

Wed Jul 18, 2018 10:47 pm
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 316
Post Re: My Research EVSA out of Space & ? Engineer
Sorry for the late reply on this.
Please explain in simple words what you'd like to achieve what exactly the platform you're using, including its P/N.

I'll do the best I can to help.

Tue Jul 24, 2018 12:15 pm

Joined: Wed Aug 29, 2012 12:18 am
Posts: 67
Post Re: My Research EVSA out of Space & ? Engineer

I simply want to flash the BIOS back to ver 3 or above.

I can't. The It say "EVSA Out Space". FIT-PC, Compu Lab and Phoenix
are doing nothing to provide a Software solution to the issue.

I used Linux FWTS. Most the space is free. only 8K needs reclaimed.
You can make delete variables just fine. But when copies the Capsule theirs not enough EVSA space some how. Thus it doesn't do the job.

Just how much free EVSA space is need to flash the UEFI BIOS anyway.
I question that in the first space.

If the capsule copied into the memory area. Why does it need EVSA memory in the first place.

We the customer need a Space cleanup app. But no one contact phoenix on this.

You just leave the customer hanging. I don't want to pay a whole bunch of money for you to pull the chips and re-flash them with possibility of not even getting my machine back. Money would be better spent on a new machine with better specs and bios.

I've trying to get out from under the issue so far myself. If the is EVSA that means it EFI Variable storage area. Now there is a primary area and secondary. To cleanup the primary area you format the Secondary area and copy the most current version of the variable to the secondary then format the Primary then copy the secondary back to the primary area. And WaLa. You should remain any deleted space that had not be reclaimed as free. The 8K. That would provide the maximum free EVSA space. This is what the Fault Tolerant Write Process does. It a function inside Tiano. But it not suppose to engage unless your running out of space. So I tried to force it to engage. I created boot entries that used more than 50% of the free space. but no luck. the 8K wasn't freed up. So deleted my entries. Lost just a bit more space in the attempt.

Maybe it doesn't engage until 80 or 90% mark. I don't know what the trip point is set to. Only you or Phoenix knows the answer to that.

I do know at %50+ used up the machine does countless short and not full reboots before finally doing a full reboot. I deleted the variables and it still did when I was done. I ran FWTS from sudo -s. That somehow fixes the issues so it reboots more normally.

Now the UEFI Bios is a bit broke. Both Samsung Drive Magician (any version) and Intel Driver Updater fail to work in Windows 7Pro 64. They never seem to find the hardware. But at least the IntensePc is stable running windows. Running FWTS the first time fixed that issue.

I wish we just had a designed tool to clean up the space and engage FTW directly fro UEFI here.

Thu Jul 26, 2018 2:45 am
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 316
Post Re: My Research EVSA out of Space & ? Engineer
Why would you want to downgrade the BIOS version?
What is the actual phenomenon you are exhibiting when working with the machine?
You've stated that the intensePC is stable running windows, where is the issue?

Wed Aug 01, 2018 2:29 pm

Joined: Wed Aug 29, 2012 12:18 am
Posts: 67
Post Re: My Research EVSA out of Space & ? Engineer
My Issues have always been simple:

1) I can't upgrade the firmware back to v3,4,5. Because of the EVSA out of space error issue. And nobody going to Phoenix here to get a software tool to fix the issue and manual clean up the memory space.

2) Software like Samsung Drive Magician and Intel Driver Update no long work. They just run for forever like they are looking for resource and not getting/finding it.

Now I could send the machine in for repair. But I'll just hold out for the future machine. Which you haven't built yet. IPC3 and IPC3v2 wasn't it.
Airtop2 is Vertical and too big. Nice Machine but already out of date.

The next machine must have 10Gb Lan or Thunder Bolt 3 that allows for a Thunderbolt3 to 10Gb Adapter (House wired for Cat6a now. ). Dual NVMes 2280 running 4pipes each. Quad core if possible in the foot print of the IntensePC.

Have though about the newest NUC8. But seem there a cheap Fan issue on that machine.

Would be nice to have a real graphics chip. 1080 and 4K video.

UEFI Bios can't be Tiano. I don't like what I'm seeing.

Mon Aug 13, 2018 10:59 pm
Site Admin

Joined: Mon Dec 25, 2017 4:21 pm
Posts: 316
Post Re: My Research EVSA out of Space & ? Engineer
You're welcome to email me to the support mailbox
If there's functional issue we can help resolve please let us know.

Tue Aug 14, 2018 11:51 am
Display posts from previous:  Sort by  
Reply to topic   [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.